Buttons not working

0

Hi Don, this is for you.

Recently I found that many of the UI buttons on your site don't work anymore. This includes the Discussion and Add to Discussion buttons and now I found the Remove button also didn't respond. All of these errors are demonstrable in this thread.

Regards,

Edit 02 Aug 2018   ===============================

I saw your test discussion and found the button below it unresponsive as are the appropriate buttons in this thread. I don't like to use Chrome because of my location. My browser is latest IE and I think your site should permit its use. It did until very recently lol:

Edit 03 Aug 2018   ===============================

I don't use any add-ons with my IE, at least none that I am aware of. I also have the same problem with iOS. If there is a difference in my behaviour as compared to before it is that I use the iPad to log in occasionally now.

Edit 03 Aug 2018 PM   ============================

What I'm saying is that I have the same problem on the iPad and the PC. I just never used the iPad for this site before and first encountered the unresponsive buttons on iOS. I attributed it to Safari but now I have the same problem on the PC. It's all the discussion buttons and the Remove (attachments) button. I can still attach workbooks and answer questions. I can also edit both questions and answers.

I use IE 11 on WIN 8.1

Edit 07 Aug 2018   ================================

Edge is designed for Win 10 and using it on WIN 8.1 looks adventurous at best. I do appreciate your effort to enable my uninhibited access to TeachExcel but wonder if that point is so terribly important. At a guess, the large majority of your visitors still use IE and versions of Windows even older than 8. I think you have the good fortune that I'm telling you what's wrong and keeping me happy (quiet) will not solve the problem. I think the interesting question is whether, using Win 8.1 / IE 11, the same problem occurs in other jurisdictions. Have you been able to make that test at home? I intend to do so when I travel next.

Edit 08 Aug 2018   =============================

I decided to kiss IE good bye since even MS doesn't support it anymore. It isn't that Chrome doesn't work. I just don't like all the gadgets and links that are second nature to Chrome being blocked. Anyway, I shall try to make Chrome my default from now on. Bad news for you though. Your buttons still don't work. In fact, that was to be expected since they don't work on iOS either. I think it's the Great Firewall targetting Java. For the past year or so (long before your trouble started) I've been getting the message "StackOverflow requires external JavaScript from another domain, which is blocked or failed to load.", also on both iOS and IE. If you kn ow which domain that is I might be able to assist with some research on it. However, I presume that Java is aware of it and would have done something about it long ago if it weren't political.

Answer
Discuss

Discussion

It works just fine for me, I just made a comment under your answer. Can you tell me what browser and operating system you are using? Also, tell me any browser add-ons that you might be using. It could be an issue with a particular setup that I don't regularly test.
don (rep: 1725) Aug 2, '18 at 2:52 am
Try using Chrome to reply to this, as that is what I use. That should ensure you can post and you can tell me the setup that wouldn't work.
don (rep: 1725) Aug 2, '18 at 2:59 am
It must have been some sort of update somewhere that I wasn't aware of. I'll look into it and see what I can find - it's probably some stray javascript again like with that issue where you couldn't see "Select All" for the code sections in Explorer until I fixed it.
don (rep: 1725) Aug 2, '18 at 6:14 am
Ok, then it might be the ipad, because I am writing this now from Internet Explorer and can't find any issues with the buttons not workting. Maybe you can try the standard "clear your cache" and restart. Is it just the "Add to Discussion" button or the "Post" button or both that is not workting?
don (rep: 1725) Aug 3, '18 at 3:39 am
Also, did you by chance turn your javascript off or limit it? Because these buttons use javascript to show the text input areas and make the posts.
don (rep: 1725) Aug 3, '18 at 3:41 am
Test post
don (rep: 1725) Aug 3, '18 at 5:21 am
What version of IE are you using? I'm using Internet Explorer 11 on Windows 10 machine. No addons or anything, just plain version.
don (rep: 1725) Aug 3, '18 at 5:31 am
Ah ok. Well I'm pretty sure that it's because of Javascript, I just can't figure out exactly why right now. Something that I don't control must have been updated and I am unable to find the exact issue right now, even when debugging the site from Chrome and IE 11. I'll keep on it though and see if a workaround can be found. 
don (rep: 1725) Aug 3, '18 at 5:34 am
Any update on your end? I still haven't been able to find the cause of the issue in IE. I will look into the workaround for the issue, but it's a rather substantial change to the working of the site so I can't guarantee that it will be able to be updated. In the meantime, you could try the Microsoft Edge browser if you want to stay with MS products.
don (rep: 1725) Aug 7, '18 at 2:53 am
I just checked the analytics and, actually, even I'm surprised by the number of people using Windows 8 with IE 11.... it's almost no one. The vast majority of people are using Chrome. I don't currently have access to Windows 8 in any form, which will make it a challenge for me to test with that setup. That said, I have tested in other browswers for Win 10 and simply haven't reproduced the error. I'll do some more problem solving with some of the tools made for Firefox and see what comes up.
don (rep: 1725) Aug 7, '18 at 9:55 am
Wowa, that is something I never thought of..... china continues to suprise me hah.  I would never imagine that javascript gets blocked like this. I'm sure then that they are blocking the jquery that gets loaded from google. This is proving to be a rather interesting situation. I'm thinking then that I should be able to solve this, if someone else hasn't already, and now I've got a bit more energy to implement a fun little workaround. I'll work on something by this weekend and msg here again after that.
don (rep: 1725) Aug 8, '18 at 11:54 am
Testing testing
don (rep: 1725) Aug 8, '18 at 12:22 pm
Ok, try it now! I found a simple and great workaround that should work in most, but not all, cases. I've tested it and it works for me, but let me know if you can use the site features now.
don (rep: 1725) Aug 8, '18 at 12:35 pm
Eureka!!! It works for me, too. Well done, Don.
But there seems to be a hair in the soup. The discussion button works superbly but the site takes almost 2 minutes to load or refresh. I posted two discussion points elsewhere and that was all the complaint I had. This particular thread seems to be special. I waited for 5 (FIVE) minutes to upload the predecessor of this post and then broke off. Then I looked for the "Accept Answer" button to award points and couldn't find it. Frankly, I don't know where it should be but I do know that it is obvious. I searched high and low - didn't find it.
Now I shall try to upload this comment. You will know if it worked. BTW, I attribute the failure to intermittent internet failure (4 bars out of 5), and that might also be the reason for slow loading and refreshing. It can't be responsible for the missing button.
Variatus (rep: 3138) Aug 8, '18 at 8:26 pm
Above upload was completed within about 30 seconds.
Variatus (rep: 3138) Aug 8, '18 at 8:27 pm
I'm glad it worked! :) The speed problem is one of the potential issues with this solution, though it should only affect those who have to load the javascript support file using the new method, meaning you basically, BUT, now that we know what the problem is, and how to fix that problem, I can work to find a better solution that loads faster.
don (rep: 1725) Aug 9, '18 at 12:12 am
For this post, there shouldn't be an Accept Answer button since I didn't technically submit an Answer, just discussion posts.
don (rep: 1725) Aug 9, '18 at 12:13 am
Then I suggest that you submit an answer lol:
Variatus (rep: 3138) Aug 9, '18 at 4:49 am
Add to Discussion



Answer the Question

You must create an account to use the forum. Create an Account or Login